Common Weakness Enumeration

CWE-436 Interpretation Conflict

Description

Product A handles inputs or steps differently than Product B, which causes A to perform incorrect actions based on its perception of B's state.

Associated Reviewed Advisories

Vulnerabilities classified under CWE-436 ordered by modification date.

25 reviewed records
Advisory ID NVD ID Severity PURLs Summary Last Modified
GHSA-23vg-4cjm-66q5 CVE-2026-100351 HIGH

kin-openapi: ValidationHandler security-requirement bypass via encoded-path operation confusion

2026-10-15
GHSA-x26q-wvhg-fh4m CVE-2026-107825 MODERATE

Coraza: ProcessURI silently drops QUERY_STRING and ARGS_GET on URI parse failure — defense-in-depth bypass for non-net/http integrations

2026-10-09
GHSA-w253-m66g-rx24 - MODERATE

Coraza: URL-encoded form Content-Type parameters bypass Coraza body inspection

2026-10-08
GHSA-3wr7-993q-jrff - MODERATE

Coraza: Multipart filename* (RFC 5987) charset restriction lets a decoy filename bypass FILES-based rules

2026-10-08
GHSA-g4qm-m288-5cp9 - MODERATE

Coraza has Cookie Parser Confusion

2026-10-08
GHSA-5gj4-9gm7-2fx2 - MODERATE

Coraza body processor has a JSON key collision that allows unauthenticated attackers to bypass OWASP CRS inspection

2026-10-08
GHSA-p75x-jh7p-ppcx CVE-2026-106505 HIGH

Backstage: Bypass of MkDocs configuration sanitizer in TechDocs backend

2026-10-07
GHSA-j4jc-cq9h-xrhr CVE-2026-68968 HIGH

Apache Airflow Backfill API parser discrepancy permits cross-DAG authorization bypass

2026-10-02
GHSA-9c5c-9qcx-q35q - HIGH

@nestjs/platform-fastify: Path-scoped middleware bypass via absolute-form request targets

2026-09-30
GHSA-jvvf-x445-j334 CVE-2026-86818 MODERATE

fast-uri vulnerable to mailto header injection via percent-encoded field-name desynchronization

2026-09-29
GHSA-g57g-f23g-4646 - MODERATE

Nodemailer: Quoted local-part can produce malformed envelope recipient through RFC 5322 comment parsing

2026-09-29
GHSA-p634-w6r4-rjp2 - MODERATE

adm-zip: Duplicate ZIP entry names: getEntry() and extractAllTo() resolve to different content

2026-09-29
GHSA-58mr-gqgx-xq4g CVE-2026-84394 HIGH

fast-uri vulnerable to host confusion via an unclosed bracket in the URI authority

2026-09-28
GHSA-9643-4qgh-g8mx CVE-2026-56669 HIGH

elysia has Inefficient Algorithmic Complexity and Interpretation Conflict

2026-09-23
GHSA-39wr-7q6h-cf68 - HIGH

LMDeploy has an SSRF bypass

2026-09-18
GHSA-4c8g-83qw-93j6 CVE-2026-13676 HIGH

fast-uri vulnerable to host confusion via failed IDN canonicalization

2026-09-11
GHSA-v67p-phpq-fc8x CVE-2026-88004 HIGH

Traefik entrypoint header-name sanitization bypassed via request trailers

2026-09-10
GHSA-wmmp-3585-3rmp - MODERATE

Nodemailer: IDN/Punycode domain allow-list bypass leads to email delivery to an attacker-controlled domain

2026-09-08
GHSA-cc9r-2j5m-2m83 - MODERATE

Nodemailer: Recipient-domain validation bypass via RFC 5322 comment mis-parsing leads to email delivery to an attacker-controlled domain

2026-09-08
GHSA-78x9-fhhx-v2g6 CVE-2026-73846 MODERATE

CKAN MCP Server: Cache-key canonicalization collision enables cache confusion / poisoning

2026-09-03
GHSA-mvxr-6m87-mv2q CVE-2026-63435 MODERATE

Mail: Email address spoofing via malformed RFC 2047 encoded-words

2026-09-02
GHSA-5jgf-p345-68v8 CVE-2026-75931 HIGH

fast-uri vulnerable to host confusion via skipped IDN canonicalization on scheme-relative references

2026-09-02
GHSA-v39h-62p7-jpjc CVE-2026-6322 HIGH

fast-uri vulnerable to host confusion via percent-encoded authority delimiters

2026-09-01
GHSA-j4h9-pm27-4rfw CVE-2026-54134 HIGH

OctoPrint has possible file exfiltration via query parameters on upload endpoints

2026-08-21
GHSA-v5mv-p594-2x33 CVE-2026-69246 HIGH -

Guzzle: Noncanonical host can bypass host-based checks

2026-08-03